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i. License
ANTEVS is free software, however you may not redistribute or post it online without the 
author's permission. It may only be distributed as the released compressed file package with this 
file and other included files. Any significant usage, such as a resulting presentation or 
publication, should include attribution to the program and author as follows:

Rayburn, J.A., and Vollmer, F.W., 2013. ANTEVS: A quantitative varve sequence cross-
correlation technique with examples from the northeastern United States. GFF: Journal of the 
Geological Society of Sweden, v. 135, p 282-292.

Vollmer, F.W., 2014. ANTEVS: Automatic Numerical Time-series Evaluation of Varying 
Sequences software. Retrieved from: www.frederickvollmer.com/antevs.

ANTEVS is Copyright © 2011-2014 Frederick W. Vollmer. This program is distributed in the 
hope that it will be useful, but without any warranty; without even the implied warranty of 
merchantability or fitness for a particular purpose. 

http://www.frederickvollmer.com/antevs


1. Introduction
ANTEVS (Automatic Numerical Time-series Evaluation of Varying Sequences) is a program for 
correlating time varying sequences such as glacial varve sequences and tree-rings. It was 
developed for the correlation of glacial varve sequences (Rayburn and Vollmer, 2013), however 
it includes standard techniques for matching tree-ring sequences, and can convert files between 
varve and tree-ring formats. Version 1.1 includes routines for reading the Velmex UniSlide 
digital readout used for tree-ring measurements. It is used extensively in John Rayburn's varve 
and tree-ring laboratory at SUNY New Paltz, and is specially designed for ease of use, and to 
assist with undergraduate student and other research projects. 

ANTEVS is written using the cross-platform open source Free Pascal compiler and Lazarus IDE.
It is developed on Macintosh OS X and is compiled for Macintosh OS X, Windows, and Linux. 
Currently testing is done on OS X 10.6, 10.8, Windows XP, Windows 7, and Linux Ubuntu. User
input is appreciated to improve operation on various platforms.

2. Installation
On Macintosh OS X, double click the disk image file (.dmg), and drag the Antevs application to 
your Applications folder, or other desired location. 

On Windows, unzip the zip file (.zip) using the “Extract All” option, and drag the Antevs folder 
to any desired location. The Antevs folder contains the Antevs application (Antevs.exe), and a 
Resources folder which is required. 

On Linux unpack the gzip file (.tar.gz), and copy the Antevs folder to any desired location. The 
Antevs folder contains the Antevs application (antevs), and a Resources folder which is required.

3. Example Usage
To test the correlation of glacial varve series from the Hudson Valley at Newburgh, NY with the 
Connecticut Valley at Hartford, CT, download the following North American Varve Chronology 
(NAVC) Normal Curves files from the North American Glacial Varve Project website (data from 
Antevs, 1922): 

HUD29-32AM.TXT
CON28-32AM.TXT

or open the included TSV (tab-separated value) files:

HUD29-32AM.tsv
CON28-32AM.tsv

Assume one is known and the other is unknown, so open HUD29-32AM as an unknown and 
CON28-32AM as a chronology (Figure 1). Select them both, and use the command Analyze > 
Data Graph to view the raw data (Figure 2). Note that the differences in scaling and long 



wavelength trends makes any correlation difficult to see.

 

To detrend and rescale the data select Analyze > Detrend to open the Preferences dialog, and 
set Detrend on, with a 16 term Fourier curve fit, using the Standardized normalization method 
(Figure 3). In the View pane check Detrended data for both Unknown and Chronology 

Figure 1. ANTEVS Data Window with an unknown and a chronology file 
open and selected.

Figure 2. Data Graph showing the two raw varve example data sets.



(Figure 4), and press OK.

The data graph will update to show the data detrended by removing long wavelenghs trends 
using a 16 term Fourier curve, and normalizing using standard deviations of the residuals, 
making the correlation more clear (Figure 5). To perform a cross-correlation and view the 
resulting correlogram, select Analyze > Correlogram (Figure 6). Use the mouse to examine the 

Figure 3. Preference dialog Detrend pane with 
Detrend on, and default Fourier settings.

Figure 4. Preferences View pane with Raw data and
Detended data checked on for display.



r correlation values. Note the strong spike at offset 0 and r = 0.643, the best correlation. 

Finally, select Analyze > Bin Test to see how subsets of the unknown match the known 
chronology. The default bin size is 100, with a minimum overlap of 60 varies. Most of the 
subsets match with zero offset suggesting a robust match. 

Figure 6. Correlogram for two varve sequences showing spike at the best 
matching year with r = 0.643, z = 6.516.

Figure 5. Data graphs of raw and detrended data using a 16
term Fourier series.



Tests on NAVC varve data sets known to be correlated suggest that a correlogram with a single 
spike with r >= 0.6 and z >= 6 is a good potential correlation for varves (Rayburn and Vollmer, 
2013). However, definitive correlation acceptance criteria are difficult to quantify, rather, Antevs 
provides statistical and graphical tools for the evaluation of sequences, recognizing that the 
ultimate decision for correlation, whether tree-rings, varves, or other time series, lies with the 
researcher (Grissino-Mayer, 2001; Rayburn and Vollmer, 2013).

4. Data Files
Eight data file formats are supported. A simple tab-separated value (TSV or TAB) format for 
varve data, consists of comment lines (optional), a header identifying the data columns, and data 
lines. Examples:

// Hudson Valley; Newburgh; NY
// This is a comment
//
Year<tab>Raw<tab>Comment 
2900<tab>44.300
2901<tab>25.500

Headers can include: Year, Raw, Total (= Raw), Thickness (= Raw), Fit, Detrend, Count, 
and Mean (= Raw). Count and Mean are output headers used when creating a mean varve 
chronology. Summer, Winter, Comment, and Note (= Comment) headers are also read and 
written, but are not otherwise used. It is best to avoid commas in comment lines. The TSV file 
format is recommended over the space-delimited TXT format, as it are can be read and written 
by most spreadsheet programs, and the comment and header lines provide self-documentation of 
the content.

A comma-separated value (CSV) format is identical to the TSV format, but uses commas as data 
delimiters. Note that commas in data fields can potentially cause problems. This format can be 

Figure 7. Bin correlogram for varve data suggesting a robust fit at 0 year 
offset.



also read and written by most spreadsheet programs.

A space-delimited format (TXT), which is for a single sample and has varve year or sequence 
number (first column), and total thickness as decimal values in centimeters in the second column.
If four columns are detected they are assumed to be year, summer thickness, winter thickness, 
total thickness. A TSV format is recommended over this format.

Three additional formats used by spreadsheet programs such as LibreOffice Calc and Microsoft 
Excel are supported: OpenDocument (ODS), Office Open XML (XLSX), and Excel (XLS) 
spreadsheet formats. The spreadsheet may have comments at the beginning starting with “//”, and
must have a header line as described above. 

A decadal tree ring raw format (RWL) contains fixed column records with core id, decade or 
start year, and thicknesses. Multiple cores per file are supported. Thicknesses are stored as six 
digit integers in units of 0.01 mm or 0.001 mm. The 'Precision' command can be used to set the 
precision to 2 or 3 places before reading or writing a file (default is 3). 

A tree ring chronology format (CRN) that contains a single composite chronology which is 
standardized to a mean value of 1. 

5. Analyze Commands

5.1 Detrend

Detrending rescales the raw data and removes longer wavelength trends by fitting a curve to the 
data set, and adjusting the raw data values using the fitted values. This allows sequences with 
different environmental inputs to be more easily correlated, such as distal and proximal varves, 
or young and old tree-ring growth.

5.1.1 Mean 

Fits to the mean of y.

5.1.2 Linear 

Fits a linear curve:

f = a + bx 

by minimizing the squared residuals in y.

5.1.3 Quadratic

Fits a quadratic curve:

f = a  + bx + cx2

by minimizing the squared residuals in y.



5.1.4 Cubic

Fits a cubic curve:

f = a + bx + cx2 + dx3

by minimizing the squared residuals in y.

5.1.5 Exponential

Fits an exponential curve:

f = aebx + c

to the data by minimizing the squared residuals in y using an iterative method. This can be useful
for tree-rings that have a regular decrease in width with age, but can fail in many cases.

5.1.6 Automatic

For cubic, quadratic and linear curve fitting a fit is rejected if a negative thickness is predicted, 
and a lower order curve is tried, until the mean is used. For an exponential fit, the curve is 
rejected with b > 0 or c < 0, and a linear curve fit is tried. If a linear fit is rejected with b > 0, or a
negative thickness is predicted, the data is fits to the mean value of y. Automatic exponential is a 
good choice for many tree-ring data sets.

5.1.7 Spline

Fits a cubic spline to the raw data. The Stiffness parameter controls the tightness of the curve 
(Cook and Peters, 1981). 

5.1.8 Fourier

Fits a Fourier series to the raw data. The Low pass frequencies parameter controls the number 
of components in the series. This is the default method used for varve analysis, with a default 
setting of 16 (Rayburn and Vollmer, 2013).

5.1.9 Method

The Detrend Method sets the method by which the fit curve is used to detrend the raw data.

5.1.9.1 Fit

Displays the fit curve, ŷi.

5.1.9.2 Residual

The residuals method uses the residuals, subtracting the predicted value, ŷ i , from the 
data value, yi: 

ri = (yi – ŷi)

These are not normalized, so units are in centimeters or millimeters, with a mean of 
zero.



5.1.9.3 Standardized

Standardizes, or normalizes, the residuals by dividing by the standard deviation of residuals. This
allows comparison of differing series as units are removed and data is transformed to standard 
deviations from the fit curve. The mean of detrended values will be zero. This is the default 
method for varve analysis.

5.1.9.4 Ratio

Uses the ratio method (yi / ŷi) commonly used for tree rings. This can be biased 
however, and using residuals is more robust. Values of ŷ i  near zero are discarded. The 
mean of detrended values will be 1.

5.2 Filter

Displays the flters dialog. Filters are applied after detrending the data to normalize the 
data and to potentially emphasize correlations. Normalizing involves smoothing the data
by using neighboring values. 

5.2.1 Delta Bar

Smooths using the average of the nearest neighboring data points:

y' = (yi-1 + yi + yi+1)/3

Rayburn and Vollmer (2013) suggest this filter may help emphasize some varve correlations.

5.2.2 Cubic derivative

Orthogonal cubic first derivative filter. Smooths using the cubic derivative of the nearest 
neighboring data points. This filters the data to look for changes in slope of the series using the 
first derivative of a local cubic polynomial. The number of terms can be 5, 7, or 9. The 5 term 
cubic derivative filter can be particularly effective for correlation.

5.2.3 Ratio

Smooths using the ratio of current and previous years: 

yi' = yi / yi-1

5.2.4 Natural

Logarithmic, or natural, change from previous year to current year (Hollstein): 

yi' = ln(yi / yi-1)

5.2.5 Relative

Relative change from previous to current year: 

yi' = (yi - yi-1) / yi-1



5.2.6 Log five year

Five year logarithmic smoothing filter (Baillie and Pilcher, 1973): 

yi' = ln(5 * xi
2) / (xi-2 + xi-1 + xi + xi+1 + xi+2))

5.3 Mean

Calculates a mean master series of all data series, either chronologies or unknowns. Each series 
is detrended before calculating the mean, and a detrend filter option should be selected from the 
Filters dialog before creating a mean. The data series are not normalized when calculating the 
mean, so the normalize filter setting does not matter. The detrend method should be either ratio 
or standard residual.

5.4 Data Graph

Graphs unknown and chronology thickness, or normalized thicknesses, versus year. Optionally 
plots best fit curves and raw data for unknowns and chronologies.

5.5 Cross-Correlation

Applies the current filters, first detrend then normalize, and calculates the cross-correlations and 
t statistics for each possible match. The default overlap required for a test is 60, this can be 
changed in the Preferences Limits panel.

5.6 Bin Test

Sequentially groups the unknown data into bins, similar to bootstrapping, and runs each against 
the selected chronology displaying the best correlations based on the t statistic. Used to test the 
robustness of the match and to potentially locate missing varves or tree-rings in an unknown. The
bin size can be changed in the Preferences Limits pane. The bin size must be larger than the 
minimum overlap.

6. Data Collection
Antevs 1.1 allows data collection for the Velmex Unislide digital readout system, commonly 
used for tree-ring measurements. This has been successfully tested on Windows and Macintosh 
systems. To collect data measurements, click on the Unknown list and use the File > New 
command to create a new file. Select the file, rename it as desired, and select Edit > Edit Data. 
In the Data Edit Window, select Edit > Connect and enter the required serial port parameters. 

Antevs is set for the default parameters that work in our laboratory on Windows (COM3, 9600 
baud, 8 data bits, 2 stop bits, no party, no flow control), however these will depend on your 
specific setup. On the Macintosh open the Terminal from the Applications Utilities, and enter the 
following command:

ls /dev/tty.*



This will list the available serial ports. For the Macintosh using a Prolific PL2303 chip set serial 
USB converter (such as the Manhattan USB to Serial Converter), the required port is:

/dev/tty.usbserial

This port with the above parameters works in our laboratory. An open source driver is available 
for the PL2303 that works on Macintosh, and is included on the Linux Ubuntu distribution.

Once the connection has been made, use the command Edit > Read to begin data collection. 
Antevs will prompt the user for the start year, and then the initial coordinate at the beginning of 
the first tree-ring measurement. Following initialization, subsequent entries will input the raw 
tree-ring widths. Data entry may be paused at any time, and continued by reinitializing the start 
point. An audible signal indicates input of each decade.

Future versions of Antevs will attempt to connect with other data collection devices. The author 
will work with researchers who are attempting to automate their data collection, currently this 
must be through a serial port connection. 
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8. History
1.1.0 (2014-10-04)
• Updated to minor version 1.
• Internal modifications to file save routines.
• Changed Edit > Clear command to File > Close, and added Cmd-W accelerator key.
• Changed Auto-Update default to true.
• Grids now save column widths between sessions.
• Moved Analyze > Refresh to View > Refresh, fixed disabled command when Auto-Update 

is off, changed accelerator key from Cmd-H to Cmd-R.
• Paint pickers updated to use opacity.
• Added ability to open Excel XLS and XLSX files.
• Fix to correctly save initial comment lines in File > Save As.
• Modified data collection routines to ask for initial date.
• Linux: Fixed image centering bug using work around.
• Linux: Fixed Preference dialog so visible pane always matches panel listbox selection.
• Expanded User Manual.

1.0.6 (2014-02-23)
• Numerous changes to the Data Edit Window to implement reading the Velmex UniSlide 

digital readout for logging tree-ring data. See section in ANTEVS User Manual on Data 
Collection.

• Implemented messaging to replace global flags and minimize recalculations.
• Fixed and bug that was disallowing multiple open series for some formats.
• Added warnings for saving data.
• Disallowed opening series with identical names. 
• Fixes to File Save dialog.
• Added Save As command to Data Edit window.
• Changed the name from ANTEVS (Automatic Numerical Time-series Evaluation of Varve 

Sequences) to ANTEVS (Automatic Numerical Time-series Evaluation of Varying 
Sequences).

1.0.5 (2013-04-29)
• Fixed Revert command in data edit window. This command reverts the data to the last time it 

was opened or saved.
• Added Select All command.
• Removed depreciated Clear All command, use Select All + Clear commands.
• Made Precision apply to displayed data as well as file output.
• Added ODS (OpenDocument), XLS, and XLSX spreadsheet formats to Save As command. 
• Added Export Sets command to save all selected data sets in one TSV, CSV, ODS, XLS, 

XLSX, or RWL (decadal) format file. See Brewer et al., 2011.
• Added ODS spreadsheet format to Open command.

http://www.frederickvollmer.com/antevs


• Open command now detects and opens TSV, CSV, ODS files, in addition to RWL format files,
to open multiple sets files created with Export Sets command. 

1.0.4 (2013-04-22)
• Grouped graph components in SVG output for easier editing.
• Fixed text vertical alignment in SVG output.
• Changed menu item Save As Vector Graphics to Export SVG.
• Removed Unicode => symbol, not recognized by AI Helvetica.
• Added target CPU and system info to About dialog box.
• Added comment editing.
• Added Split command to split, join and renumber data measurements.
• Removed depreciated Combine command.
• Preference file modifications.

1.0.3 (2013-04-08)
• Fixed floating point error caused if detrend curve exactly equals data.
• Fixed preference button hints.
• Allow opening of Preference dialog without selecting or opening data. 
• Added menu options to open Preference dialog Detrend and Filter pages.
• Added fit curve color selection.
• Added About dialog.
• Compiled with FPC 2.6.2, LCL 1.0.8.

1.0.2 (2013-04-01)
• Fixed bug causing freeze when opening Precision dialog.
• Precision now stored in preference file.
• Precision settings moved to Preferences dialog.
• Added ANTEVS header to TXT files.
• Changed default file type to TSV (tab separated values).
• Modified Save As for TXT, TSV, CSV files to save Year and Raw columns only.
• Added z score, standard deviation, count,  and offset to cross-correlation graph.
• Changed precision to three places in cross-correlation display.
• Displayed maximum t value now always corresponds to maximum r value.
• Added p to t graph.
• Changed title of 'Filters' dialog box to 'Preferences'.
• Changed page selection in preference dialog to combobox.
• Detrend, Filters, and View preferences are now saved to preference file.
• Added option to turn off display of cross-correlation significance in Preferences Options tab.
• Added stroke selection for graph data.
• Fixed runs trend bug.

1.0.1 (2013--03-16)
• Compiled with Free Pascal 2.6.0 and Lazarus 1.0.6.
• Fixed missing tick marks bug. 
• Fixed tick marks stroke color.
• Fixed vector font export bug, fonts are now filled instead of stroked.



• Fixed incorrect log references.
• Fixed fill color bug in SVG export.

1.0.0 (2012-10-31)
• First official release for review.

0.0.20 (2012-09-18)
• Compiled with Free Pascal 2.6 and Lazarus 1.0.
• Fixed Save As command to save raw data instead of detrended data.
• Added new Save Detrend command saves detrended data.
• Added preliminary frequency spectrum (periodogram) graph, use Window > Fequency to 

view.

0.0.19 (2012-04-15)
• Added multiple colors to data graph.

0.0.18 (2012-04-08)
• Recompiled on Free Pascal 2.6.0.
• Added Spline detrending, following COFECHA. 
• Added Log transform for the Ratio method, following COFECHA.
• Added csv and tsv data files for both raw data and mean masters. 
• Combined file formats into Open and Save As dialogs, and removed multiple Open and 

Save As commands.
• Removed Delta bar past filter. 
• Added Link checkbox to link unknown and chronology detrend methods.
• Added max and mean labels to correlogram and bin graphs.
• TODO: Interpolate missing values.
• TODO: Debug RWL and CRN missing value and end data values, 999, -999, -9999, etc.

0.0.17 (2012-02-24)
• Added ability to select and view multiple data sets by control (Windows) or command (Mac) 

clicking. Note that only the first selected file in the unknown and chronology grids is used for 
most operations (cross correlation, saving files, etc.).

• Added data windowing with panning to allow detailed view and stepping through data.
• Added cross-correlation of data window.
• Added Count column in data edit grid, this gives data counts for means and CRN files.
• Fixed memory leak.
• Added Save As CRN Chronology for mean and CRN data series.  
• Enabled Preferences command on Mac (same as Filters).

0.0.16 (2012-02-05)
• Added Fourier detrending for variable terms. 
• Added two delta filters mainly for use with Standardize detrend method. These are more 

stable and handle zero thicknesses naturally (no division by zero). Note the Cubic derivative 
is also stable. Note that the common Ratio method normalize filters do not work well with the
Standardize detrend method, because the mean is zero instead of one.



• Added Delta bar filter: y1' = y1 - (y0+y1+y2)/3.
• Added Delta bar past filter: y3' = y3 - (y0+y1+y2)/3. 
• Removed Difference filter, this was identical to Delta bar past with 1 term.
• Removed polynomial smoothing detrending as not effective, was similar to Fourier with many

terms.
• Removed quadratic polynomial derivative filter as not effective, overly smoothed data.
• Added mean toolbutton.
• Added detrend Fit method, this gives the fit curve for display or saving to file. It is not useful 

for correlation.
• Stacked raw, detrend, and filtered data graphs.
• Numerous additional fixes.

0.0.15 (2012-02-19)
• Changed name to ANTEVS (Automatic Numerical Time-series Evaluation of Varve 

Sequences), or Antevs.
• Added automatic option for detrending polynomial curve fitting. See Detrend above.
• Changed automatic exponential to reject linear fits that predict negative thicknesses. This 

removes some errors in detrending (e.g., calculating a mean for ny005.rwl, series 22).
• Added orthogonal quadratic polynomial smoothing filters. See Normalize above.
• Added orthogonal quadratic and cubic polynomial first derivative filters. See Normalize 

above. 
• No longer saves window size when maximized.
• Added residuals and standard residuals detrend methods. See Detrend above.
• Added data series name edit.
• Made Filters dialog nonmodal.
• Added Detrended column to Data Edit grid.
• Enabled Quit command in Windows.

0.0.14 (2012-02-16)
• Fixed saving of mean files.
• Rewrote handling of zero thicknesses, only used during normalization to avoid division by 

zero or log zero. 
• Stacked graphs with scales on all curves.
• Fixed update of Data Edit grid when a chronology is viewed.
• Fixed update of main data set grid after editing data.
• Optional runs trend calculation is done simultaneously and viewed on a separate stacked 

graph.
• Runs trend algorithm is modified slightly following Corina; an up/down/same = 

up/down/same match gets +1, a same = up/down gets +0.5, otherwise no match gets 0.

0.0.13 (2012-02-06)
• Rewrote cross-correlation procedure to minimize potential round off, no change in 

functionality.
• Fixed bug in graph frame drawing.
• Fixed bug in exponential fitting, was not fully converging.
• Added y scale labels to data graph for raw data on right. Filtered data scale remains on left. 



Grid is drawn for filtered data unless only raw or detrend fit is on. 
• Fixed Clear tool button, was not working.
• Fixed two bugs causing random errors in mean calculation.
• Changed menu text from "Cross-Correlation" to "Correlation", no change in functionality.

0.0.12 (2012-02-05)
• Added Zoom commands and controls, including mouse dragging.
• Fixed Accept Edits command in Data Edit window, was not keeping edits.
• Changed Processed to Filtered for clarity.
• Changed Data View to Data Edit.
• Added toolbar to Data Set window.
• Added data names to graphs.
• Fixed y axis scaling error on data graph.
• Added correlogram caption.
• Linked Filter Normalize controls, so changing unknown now changes chronology. Added an 

option to turn linking off, but there is no reason for these to differ. May combine in next 
version.

• Fixed Save As, was not enabled.
• Added more information in status bar.

0.0.11 (2012-01-28)
• Added graphics buffer to fix slow redraw on Windows. 
• Fixed focus loss when closing filters dialog on Windows.
• Fixed divide by zero error

0.0.10 (2012-01-28)
• Fixed window position xml preferences
• Fixed error reading rwl, 999 entries now excluded as well as -9999
• Fixed data view, was not updating on data grid focus change
• Enabled view detrend as always available
• Fixed error in mean calculation, was not detrending with correct settings
• Added save view options in preferences
• Fixed divide by zero error

0.0.9 (2012-01-25)
• Internal changes for easier maintanence
• Fixed compatibility with OS X 10.5

0.0.8 (2012-01-18)
• Added graph of offset values to bin test correlogram.
• Added color keys for curves on graphs.
• Restored ability to calculate mean chronology.
• Restored option to view log output.
• Fixed bugs in bin test.
• Made auto-refresh optional.
• Added Refresh command and toolbar buttons.



• Fixed label and grid spacings to auto-size.
• Added ability to open CRN files.
• Added ability to detect and  open four column TXT files.
• TXT file is checked for non-sequential values.
• Added Open command that uses file extension to determine file type.
• Added quadratic and cubic detrending options.
• Turned off automatic renumbering when editing a file.
• Added Renumber command.

0.0.7 (2012-01-08)
• Completed graphical display of bin test and data display.
• Simplified analyze options.
• Depreciated log test display window.
• Added curve fitting and detrending algorithms.
• Implemented Marquardt non-linear curve fitting.
• Added best-fit curve display to data graph window.
• Redesignated growth correlations as normalize filters, e.g., Natural and Difference.
• Added additional normalize filters, e.g., Log five year and Two year sum.
• Depreciated cross-association (available in Filters Extra tab).
• Depreciated runs analysis (available in Filters Extra tab as SIgn).
• Experimental implementation of area correction algorithm (depreciated).
• Implemented chronology data display. 
• Implemented unknown data editing with preview and restore.
• Added minimum thickness value with default of 0.001.
• Added automatic update of Data View, Data Graph, Bin Test and Correlogram windows.
• Created new icon.
• Added preference file to remember window locations and sizes.
• Added vector graphics SVG output of graphs.
• Added PNG, BMG, and JPG bitmap output of graphs.

0.0.6 (2011-12-11)
• Added Graph Window.
• Added Thickness Graph.
• Added Growth Graph.
• Added year offsets to Log Window anaylses to assist in locating matches.

0.0.5 (2011-12-03)
• Added 'Precision' command to set precisions in files to avoid precision loss when converting 

varve to tree ring format.
• Enabled Analyze and Window commands from Log Window.
• Added Mean Growth command.
• Added Growth Correlation command.
• Modified Bin Test to allow setting of additional filtering parameters, including multiple 

matches per bin. 
• Added desktop icon.



0.0.4 (2011-11-21)
• Rewrote Trend Percentage algoritm.

0.0.3 (2011-11-20)
• Added Normalize.
• Added Normalized Mean.
• Added Cross-Correlation.
• Added Runs Correlation.
• Added Bin Test.
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